Get a Pad for Epic Hyperspace

Description

Scriptel signature pads are fully compatible with Hyperspace, through the use of the standard Epic API. Scriptel incorporates the API through the Hyperspace plugin, that is available in ScripTouch Sign and Save. The Scriptel solution is Citrix Ready and works with full client or VDI installations with such products as Citrix XenApp 6.5 and 7.6, or other products such as Microsoft Remote Desktop.

We recommend that users of XenApp 6.5 or Remote Desktop install ScripTouch Remote, in order to fully enable USB forwarding.

Links

Epic Hyperspace

  • Uses standard Epic API
  • Compatible with Epic Hyperspace 2012, 2014, 2015 and 2017
  • Works with client or VDI installations
  • USB forwarding option available through ScripTouch Remote
  • Windows Support
Citrix Ready